1

Тема: Ошибка при установке

При установке движка, на самом последнем этапе, а именно когда написало "Удачно завершено" в верху выбило вот эту ошибку:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; DBLayer has a deprecated constructor in /home/vlad77mk/forum.snejunka.com/include/dblayer/mysqli.php on line 16

После я перешел на свой форум (forum.snejunka.com) и в верху мне выбило уже больше ошибок. Сам форум работает вроде корректно. Что у меня не так? Как исправить?

P.S. Если захожу с телефона, то весь форум кракозябрами показывается, как-будто кодировка не та.

Поделиться

2

Re: Ошибка при установке

9badik99, в файле include/dblayer/mysqli.php (можно и в других файлах той же папки) нужно заменить

    function DBLayer($db_host, $db_username, $db_password, $db_name, $db_prefix, $foo)

на

    function __construct($db_host, $db_username, $db_password, $db_name, $db_prefix, $foo)
Моя сборка FluxBB 1.5 * Parserus - BBCode parser

Поделиться

3

Re: Ошибка при установке

Visman, у меня есть такое:

function DBLayer($db_host, $db_username, $db_password, $db_name, $db_prefix, $p_connect)

В конце немного другой код. Заменил его на данный Вами код. Ничего не произошло. Ошибки так и остались.

Поделиться

4

Re: Ошибка при установке

В той папке несколько файлов, названия у некоторых схожи  - убедитесь что вы меняете в нужном файле

Захочешь — найдешь время, не захочешь — найдешь причину.

Поделиться

5

Re: Ошибка при установке

Пардон, недоглядел. Да, все стало нормально. Спасибо Вам. Плюсик в репутацию ловите)

Поделиться