1

Тема: This PHP environment doesn't have SQLite support built in

Недавно на моём форуме появилась вот такая запись:

This PHP environment doesn't have SQLite support built in. SQLite support is required if you want to use a SQLite database to run this forum. Consult the PHP documentation for further assistance.

Попробовал запустить форум под Денвером, главная загружается, а как только переходишь по любой из ссылок, опять появляется эта надпись.

Версия стоит PunBB 1.3

В чём может быть проблема?

Поделиться

2

Re: This PHP environment doesn't have SQLite support built in

claygod, а зачем ты используешь SQLite базу данных? MySQL чем не устраивает?

Моя сборка FluxBB 1.5 * Parserus - BBCode parser

Поделиться

3

Re: This PHP environment doesn't have SQLite support built in

Visman, это холиварный вопрос. Но мне реально удобно. Кроме того, сам разрабатываю сейчас скрипт под SQLite3 - вполне практично. Ну а по поводу MySQL - когда потребуется "взрослая" БД, то скорее буду юзать PostgreSQL, правда, это будет не с РНР.

P.S. с проблемой разобрался - всё-таки на хостинге была проблема - подключён более современный SQLite3
Тут же перекинул на другой хостинг, где, вот парадокс - старый SQLite можно использовать только с PHP5.4 Рискнул - вроде всё в порядке.

P.P.S. Почему задал вопрос - как-то резко перестал работать форум и я засомневался, не прикрутил ли разработчик фичу с привязкой ко времени - типа прошло два года, как вы обновлялись - пора!

Поделиться

4

Re: This PHP environment doesn't have SQLite support built in

claygod, обычно хостер делает обновление на сервере и все ломается после этого wink

Моя сборка FluxBB 1.5 * Parserus - BBCode parser

Поделиться